Back to overview
Maintenance
Ongoing Update
May 8, 2026 at 2:50pm UTC
–
May 8, 2026 at 5:00pm UTC
Affected services
Main Systems
Caria Rcon
Hosting Panel
Resolved
May 8, 2026 at 5:00pm UTC
Maintenance ended
Affected services
Created
May 8, 2026 at 2:50pm UTC
We are currently performing an update to implement several improvements. You may experience occasional interruptions.
Affected services